Back to overview
Degraded

Issue with Stage Filters in Saved Views

Mar 31, 2026 at 8:43am UTC
Affected services
Issue Management

Resolved
Mar 31, 2026 at 8:56am UTC

Started: 12 minutes ago

Current status: Mitigated

The issue with stage filters not functioning in saved views has been resolved. Data visibility is now restored, and views are displaying correctly. Thank you for your patience while we addressed this.

Updated
Mar 31, 2026 at 8:55am UTC

Started: 11 minutes ago

Current status: Fixing

We are making progress in restoring the filtering functionality for saved views. Our team is validating the fix to ensure filters apply correctly across all data views. We will continue monitoring closely to confirm stability before reopening full access.

Updated
Mar 31, 2026 at 8:50am UTC

Started: 6 minutes ago

Current status: Fixing

We are currently working to restore proper filtering capabilities in saved views. Our team is validating the fix to ensure that data visibility is accurate and consistent. We will continue monitoring the situation closely and will provide updates as we make progress.

Updated
Mar 31, 2026 at 8:49am UTC

Started: 5 minutes ago

Current status: Acknowledged

We have confirmed that the stage filters are not functioning correctly in saved views, affecting data visibility for users. Our team is actively working on a fix to restore proper filtering capabilities and will provide an update once the issue is resolved. Thank you for your patience.

Created
Mar 31, 2026 at 8:43am UTC

Started: just now

Current status: Acknowledged

We are aware that the stage filters are not functioning correctly in saved views, which may affect how data is displayed. Our team is actively investigating the issue to identify the cause. We will provide an update in approximately 3 minutes with more details and an estimated resolution time.