Back to overview
Degraded

Devrev Tab Crashing for Some Users

Mar 31, 2026 at 8:12am UTC
Affected services
Application (app.devrev.ai)

Resolved
Mar 31, 2026 at 8:26am UTC

Started: 13 minutes ago

Current status: Mitigated

The issue causing the Devrev tab to crash and become unresponsive has been resolved. Service is now stable for affected users. We apologize for the inconvenience and appreciate your patience.

Updated
Mar 31, 2026 at 8:25am UTC

Started: 11 minutes ago

Current status: Fixing

We are actively working to resolve the ongoing crashes affecting the Devrev tab. Our team has identified the root cause and is deploying a fix, which we will monitor closely to ensure stability. We appreciate your patience as we work to restore normal functionality within the next few minutes.

Updated
Mar 31, 2026 at 8:21am UTC

Started: 8 minutes ago

Current status: Fixing

We are actively working to resolve the persistent crashing and unresponsiveness of the Devrev tab. Our team has identified the root cause and is deploying a fix, which we will monitor closely once implemented. We appreciate your patience as we work to restore normal functionality.

Updated
Mar 31, 2026 at 8:18am UTC

Started: 5 minutes ago

Current status: Acknowledged

We are aware that some users are experiencing frequent crashes and unresponsiveness in the Devrev tab. Our team is actively investigating the issue to identify the cause and implement a fix. We will provide another update in a few minutes as we make progress.

Created
Mar 31, 2026 at 8:12am UTC

Started: just now

Current status: Acknowledged

We are aware that some users are experiencing crashes and unresponsiveness when using the Devrev tab. Our team is actively investigating the issue and working to resolve it as quickly as possible. Please expect an update in the next few minutes.