Back to overview
Degraded

Customer Support Agents Not Responding

Mar 26, 2026 at 6:45am UTC
Affected services
Application (app.devrev.ai)

Resolved
Mar 26, 2026 at 6:54am UTC

The issue with DevRev customer agents not responding has been resolved. All customer agents are now operational, restoring service within the 8-minute incident window. Thank you for your patience.

Updated
Mar 26, 2026 at 6:53am UTC

We've pinpointed the issue: DevRev Customer Agents Not Respondingg. Customer impact was first seen 7 minutes ago. We're rolling out a fix now and expect it fully deployed within about 30–60 minutes—we'll update sooner if that changes. Our next status update will be in about 30 minutes.

Updated
Mar 26, 2026 at 6:52am UTC

We are continuing to investigate this issue that started 6 minutes ago. We are exploring multiple approaches and will provide another update in about an hour.

Created
Mar 26, 2026 at 6:45am UTC

Customer support agents for DevRev are currently not responding. This started just now. We will provide an update within the next 30 minutes.