Back to overview
Degraded

Email Verification Emails Not Received

Mar 10, 2026 at 3:15pm UTC
Affected services
Support Portal (support.devrev.ai)

Resolved
Mar 10, 2026 at 3:30pm UTC

The email verification issue has been resolved after a 14-minute incident. Customers can now receive verification codes as expected, and login processes are functioning normally. Thank you for your patience.

Updated
Mar 10, 2026 at 3:30pm UTC

We have identified the root cause of this issue that started 14 minutes ago. A fix is being deployed and we will provide updates on our progress.

Updated
Mar 10, 2026 at 3:27pm UTC

We have identified the root cause of this issue that started 11 minutes ago. A fix is being deployed and we will provide updates on our progress.

Updated
Mar 10, 2026 at 3:26pm UTC

We are continuing to investigate this issue that started 9 minutes ago. We are exploring multiple approaches and will provide another update in about an hour.

Created
Mar 10, 2026 at 3:15pm UTC

Some customers are experiencing delays in receiving email verification codes for portal login. This started just now. We will provide an update within the next 30 minutes.