Back to overview
Degraded

Email Verification for Customer Login Delayed

Mar 10, 2026 at 11:09am UTC
Affected services
Support Portal (support.devrev.ai)

Resolved
Mar 26, 2026 at 6:23am UTC

fixed

Updated
Mar 10, 2026 at 11:19am UTC

We have identified the root cause of this issue that started 10 minutes ago. A fix is being deployed and we will provide updates on our progress.

Updated
Mar 10, 2026 at 11:15am UTC

We are continuing to investigate this issue that started 5 minutes ago. We are exploring multiple approaches and will provide another update in about an hour.

Created
Mar 10, 2026 at 11:09am UTC

Some customers are experiencing delays in receiving email verification codes for portal access. This started just now. We will provide an update within the next 30 minutes.