Back to overview
Degraded

Computer Access Disrupted

Mar 10, 2026 at 9:20am UTC
Affected services
Application (app.devrev.ai)

Resolved
Mar 10, 2026 at 9:34am UTC

The issue affecting computers has been resolved after 14 minutes. Service is now fully restored and functioning normally. Thank you for your patience.

Updated
Mar 10, 2026 at 9:34am UTC

We have identified the root cause of this issue that started 13 minutes ago. A fix is being deployed and we will provide updates on our progress.

Updated
Mar 10, 2026 at 9:32am UTC

We have identified the root cause of this issue that started 11 minutes ago. A fix is being deployed and we will provide updates on our progress.

Updated
Mar 10, 2026 at 9:28am UTC

We have identified the root cause of this issue that started 6 minutes ago. A fix is being deployed and we will provide updates on our progress.

Updated
Mar 10, 2026 at 9:26am UTC

We are continuing to investigate this issue that started 5 minutes ago. We are exploring multiple approaches and will provide another update in about an hour.

Created
Mar 10, 2026 at 9:20am UTC

Some users are experiencing issues accessing their computers. This started 1 minutes ago. We will provide an update within the next 30 minutes.