Back to overview
Degraded

Service Disruption Notification

Feb 13, 2026 at 2:34pm UTC
Affected services
Plug Platform

Resolved
Feb 16, 2026 at 7:10am UTC

hijhhh

Created
Feb 13, 2026 at 2:34pm UTC

We are currently experiencing an issue affecting some of our services. Our team is actively working to resolve the problem and restore normal operation. We will provide updates as soon as more information becomes available. Thank you for your patience.