Back to overview
Degraded

Call Handling Delays and Freezes

Apr 6, 2026 at 5:11am UTC
Affected services
Conversation and Ticket Management

Resolved
Apr 6, 2026 at 5:21am UTC

Started: Apr 6, 2026 05:11 UTC

Current status: Mitigated

The issue causing delays and stalls during call skills has been resolved. Systems are now stable, and agent workflows are functioning normally. Thank you for your patience as we worked to restore full service.

Updated
Apr 6, 2026 at 5:20am UTC

Started: Apr 6, 2026 05:11 UTC

Current status: Fixing

We are making progress on resolving the delays that some users are experiencing when connecting to call skills. Our team is currently implementing improvements to reduce stall times and enhance overall responsiveness. We will continue monitoring the situation closely and will provide updates as we validate these changes.

Updated
Apr 6, 2026 at 5:17am UTC

Started: Apr 6, 2026 05:11 UTC

Current status: Fixing

We are making progress on resolving the delays affecting call handling and interface responsiveness. Our team is refining the fix to reduce stall times and improve overall stability. We will continue monitoring the situation closely and will provide further updates shortly.

Updated
Apr 6, 2026 at 5:16am UTC

Started: Apr 6, 2026 05:11 UTC

Current status: Acknowledged

We have identified that some agents are experiencing significant delays when using calling features, which can cause UI freezes and slow response times. Our team is actively working on resolving the underlying issue and will provide further updates soon.

Created
Apr 6, 2026 at 5:11am UTC

Started: Apr 6, 2026 05:11 UTC

Current status: Acknowledged

Customers may experience delays or brief freezes when connecting to support agents, leading to longer wait times. We are actively investigating the cause of these stalls and working to resolve the issue. Please expect our next update in approximately 3 minutes.